Home Register Arcade Gallery Chatroom Members Search Today's Posts Mark Forums Read Log In
Go Back   Inside: SereneScreen Fan Forum > SereneScreen Products > Marine Aquarium 3 for Mac OS X > Marine Aquarium 2 for Mac OS X Archive
Notices

Reply
 
Thread Tools
Old 11-28-2002, 12:48 PM   #1
Unregistered
Guest
 

Posts: n/a
Beige G3 running problem

I tried to run the demo on a Beige 333 MHz G3 running Mac OS 9.2 but it won't run. I get an error message -- "The application has unexpectedly quit". Any ideas? I'd like to purchase it, but if the demo won't run, I'm guessing the real program won't either. I also tried this on a beige 300 MHz G3 running Mac OS 9.2 but it won't run either -- same problem.

I did sucessfully get the demo to run on a 400 MHz G4, but every few seconds it freezes for a very brief time (a fraction of a second) and then continues. If I purchase the full product, will I get this freezing?

Thanks,

Brad
  Reply With Quote
Old 11-28-2002, 12:53 PM   #2
feldon34
Forum Administrator
 
feldon34's Avatar
 
Join Date: Dec 2000

Location: Rock Hill, SC
Posts: 10,920
A beige G3 Macintosh does not have any kind of 3D-capable video circuitry or video card.
"Journalism is printing what someone else does not want printed. Everything else is public relations." - George Orwell
"If voting changed anything, they'd make it illegal." - Emma Goldman
feldon34 is offline   Reply With Quote
Old 11-29-2002, 10:55 AM   #3
Michael Babin
Mac Development
 
Michael Babin's Avatar
 
Join Date: Jul 2002

Location: Rowlett, Texas
Posts: 199
The "demo" (which is actually the application, you enter a keycode to provide access to all the features) should run without problem on any Mac OS 9 system with OpenGL 1.2.1 installed. If any required component/capability is missing, the application should notify you of the problem and quit gracefully. If you're encountering an unexpected quit (crash), then we need to find the problem and remedy it. Could you send an Apple System Profiler report to me (mbabin@orderndev.com) with the details of your system (including extensions)?

If you don't have a hardware-accelerated OpenGL driver and video card, then the performance will suffer greatly, but the application will still function. For example, I've run the Mac OS 9 version of MA on my old 7500 (with a 604 processor card) under System 8.1 (with OpenGL 1.2.1 installed) without any problems, but it only has a software renderer available so the rendering speed is between 1-2 frames per second. At that speed, it really isn't "usable". A 333 MHz G3 is right on the bottom edge of the recommended range, depending on the graphics card and drivers installed. For example, an iMac with a 350 MHz G3 does provide adequate performance.

As for the "freezes" on your G4, I assume you are still referring to the Mac OS 9 version of MA. If so, then other applications/tasks can exclusively consume all the system resources (i.e., processor time) at certain points, which will cause a pause in MA. I've seen this periodic freeze occur when file sharing is starting up. It should not occur when no other applications or system tasks (such as file sharing start-up) are running.
Michael Babin is offline   Reply With Quote
Old 12-19-2002, 06:55 PM   #4
Unregistered
Guest
 

Posts: n/a
Fixed in 10.2.3?

From Apple's "Mac OS X: About the Mac OS X 10.2.3 Update":

Improves compatibility for OpenGL-based software on some computers that use ATI Rage 128 graphic accelerator chips; improves reliability for OpenGL-based software while Screen Saver effects are enabled on some computers that use ATI Rage 128 graphic accelerator chips.
  Reply With Quote
Old 12-19-2002, 07:14 PM   #5
feldon34
Forum Administrator
 
feldon34's Avatar
 
Join Date: Dec 2000

Location: Rock Hill, SC
Posts: 10,920
Let's reserve the 10.2.3 discussion to the "Mac OS X jagged display" topic.
"Journalism is printing what someone else does not want printed. Everything else is public relations." - George Orwell
"If voting changed anything, they'd make it illegal." - Emma Goldman
feldon34 is offline   Reply With Quote
Reply
Go Back   Inside: SereneScreen Fan Forum > SereneScreen Products > Marine Aquarium 3 for Mac OS X > Marine Aquarium 2 for Mac OS X Archive



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:34 AM.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.